Secondary US IP is down, we are currently investigating the reason of it
Incident Report for Short.cm
Resolved
This incident has been resolved.
Posted May 21, 2017 - 23:27 UTC
Investigating
We are currently investigating this issue.
Posted May 21, 2017 - 23:25 UTC