Major outage in admin panel
Incident Report for Short.cm
Resolved
This incident has been resolved.
Posted Sep 02, 2016 - 09:35 UTC
Investigating
We investigate problems, link shortening works correctly
Posted Sep 02, 2016 - 09:03 UTC