Link redirecting is not available for EU clients
Incident Report for Short.cm
Resolved
This incident has been resolved.
Posted Sep 28, 2018 - 12:29 UTC
Identified
Upgrade of database is in progress
Posted Sep 28, 2018 - 12:12 UTC
This incident affected: URL redirector.