Second IP outage
Incident Report for Short.cm
Resolved
This incident has been resolved.
Posted Jan 31, 2017 - 19:40 UTC
Investigating
We are currently investigating this issue.
Posted Jan 31, 2017 - 19:17 UTC